library
turbot/aws_thrifty

Correct one RDS DB instance of older generation

Overview

Older generation instance types are more expensive and less performant than the current generation equivalents, you should be using the latest generation to reduce costs and increase performance.

This pipeline allows you to specify a RDS instances and then either send a notification or attempt to perform a predefined corrective action.

Whilst it is possible to utilise this pipeline standalone, it is usually called from the correct_rds_db_instances_of_older_generation pipeline.

Params

NameTypeRequiredDescriptionDefault
titlestringYesTitle of the resource, to be used as a display name.-
credstringYesName of the credential to be used for any authenticated actions.-
approverslist of stringYesList of notifiers to be used for obtaining action/approval decisions.
[]
default_actionstringYesThe default action to use for the detected item, used if no input is provided.notify
enabled_actionslist of stringYesThe list of enabled actions to provide to approvers for selection.
[
"skip",
"delete_instance"
]
db_instance_identifierstringYesThe identifier of DB instance.-
regionstringYesAWS Region of the resource(s).-
notifierstringYesThe name of the notifier to use for sending notification messages.default
notification_levelstringYesThe verbosity level of notification messages to send. Valid options are 'verbose', 'info', 'error'.info

Outputs

This pipeline has no outputs.