library
turbot/azure
OverviewPipelines
0
Triggers
0
Variables
GitHub

Update Storage Account Minimum TLS

Update the minimum TLS version of a storage account.

Run the pipeline

To run this pipeline from your terminal:

flowpipe pipeline run azure.pipeline.update_storage_account_minimum_tls \
--arg 'subscription_id=<string>' \
--arg 'resource_group=<string>' \
--arg 'account_name=<string>' \
--arg 'minimum_tls_version=<string>'

Use this pipeline

To call this pipeline from your pipeline, use a step:

step "pipeline" "step_name" {
pipeline = azure.pipeline.update_storage_account_minimum_tls
args = {
subscription_id = <string>
resource_group = <string>
account_name = <string>
minimum_tls_version = <string>
}
}

Params

NameTypeRequiredDefaultDescription
credstringYesdefaultName for credentials to use. If not provided, the default credentials will be used.
subscription_idstringYes-Azure Subscription Id. Examples: d46d7416-f95f-4771-bbb5-529d4c766.
resource_groupstringYes-Azure Resource Group. Examples: my-rg, my-rg-123.
account_namestringYes-The storage account name.
minimum_tls_versionstringYes-The minimum TLS version to be permitted on requests to storage. The default interpretation is TLS 1.0 for this property. Accepted values: TLS1_0, TLS1_1, TLS1_2.

Outputs

NameDescription
tlsThe updated minimum TLS details.